git.iko.soy/typeable/cabal2nix
on master help sign in
hackage2nix.hs: don't upgrade to blaze-builder 0.4.x yet
94989f1Peter Simons
src/hackage2nix.hs+2−1
@@ -257,7 +257,8 @@ defaultConfiguration = Configuration
257 , compilerId = CompilerId GHC (Version [7,8,4] [])
257 , compilerId = CompilerId GHC (Version [7,8,4] [])
258
258
259 , defaultPackageOverrides = map (\s -> fromMaybe (error (show s ++ " is not a valid override selector")) (simpleParse s))
259 , defaultPackageOverrides = map (\s -> fromMaybe (error (show s ++ " is not a valid override selector")) (simpleParse s))
260+ [ "blaze-builder < 0.4" -- the new version breaks many builds, like streaming-commons
260− [ "control-monad-free < 0.6" -- newer versions don't compile with anything but GHC 7.8.x
261+ , "control-monad-free < 0.6" -- newer versions don't compile with anything but GHC 7.8.x
261 , "mtl == 2.1.*" -- newer versions require transformers > 0.4.x, which we cannot provide in GHC 7.8.x
262 , "mtl == 2.1.*" -- newer versions require transformers > 0.4.x, which we cannot provide in GHC 7.8.x
262 , "HStringTemplate < 0.8" -- 0.8 depends on time >= 1.5, which we cannot provide in GHC 7.8.x
263 , "HStringTemplate < 0.8" -- 0.8 depends on time >= 1.5, which we cannot provide in GHC 7.8.x
263 , "utf8-string < 1" -- version 1 breaks several packages right now, most notably hint
264 , "utf8-string < 1" -- version 1 breaks several packages right now, most notably hint